$re = '/[^-.\p{L}\p{Nd}\x{0590}-\x{05ff}\x{0600}-\x{06ff}]+/ui';
$str = 'asx24Å,å,Ä,ä,Ö,öaaåäöAvVBb@-
Åke.
Björn.
Åsaشآ
02156498-@#$-1234æ
ي أو فارسي
ب
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);