package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)(?:^|[^\\])(%(.*[^\\])%)`)
var str = `%name%%login%\%invalid%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}