$re = '/(?<=^|[^:]|(:))string(?!\1)/m';
$str = 'string - gets deleted
blah string - gets deleted
:string blah - gets deleted
:string: string - gets deleted
thing :string: - doesn\'t get deleted';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);