import re
regex = re.compile(r"(\d+W+)(..)", flags=re.MULTILINE)
test_str = ("Масло моторное Bardahl XTS 0W20 синтетическое 5 л 36333\n"
"Масло моторное Bardahl XTS 0W20 синтетическое 1 л 36331\n"
"Масло моторное Bardahl XTS 0W30 синтетическое 5 л 36133\n"
"Масло моторное Bardahl XTS 0W40 синтетическое 5л 36143\n"
"Масло моторное Bardahl XTS 0W40 синтетическое 1 л 36141\n"
"Масло моторное Bardahl XTC C60 0W40 синтетическое 1 л 300040\n"
"Масло моторное Bardahl XTC 10W40 полусинтетическое 5 л 36243\n"
"Масло моторное Bardahl XTC 10W40 полусинтетическое 1 л 36241\n")
subst = "\\1-\\2"
result = regex.sub(subst, test_str)
if result:
print(result)