package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z0-9\s.]+?)\s*(?:\(V\.O\.\))?(?:\(O\.S\.\))?(?:\(CONT'D\))?$`)
var str = `WILL (V.O.)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}