package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+)\s*(\S+)`)
var str = `ROSSI Mauro
Luca Giacomini
Sonny Crockett`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}