re = /^(?:0x)?[0-9A-F]+(?:[,\s-]+(?:0x)?[0-9A-F]+)*$/m
str = '0xAF,0xAF-0xAF 0xED
012345678901234567890123456789_0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end