using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(drop|reject)(.*) noalert;";
string input = @"drop tcp any any -> $HOME_NET 3389 (msg:""ET DOS Microsoft Remote Desktop (RDP) Syn then Reset 30 Second DoS Attempt""; flags:R; flow:to_server; flowbits:isset,ms.rdp.synack; flowbits:isnotset,ms.rdp.established; flowbits:unset,ms.rdp.synack; reference:cve,2012-0152; classtype:attempted-dos; noalert; sid:2014384; rev:8; metadata:created_at 2012_03_13, updated_at 2012_03_13;)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}