$re = '/^(((98)|(\+98)|(0098)|0)(9){1}[0-9]{9})+$/m';
$str = '
9121234567';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;