$re = '/^(?:\d+|5\+)$/m';
$str = '12345
5+
10+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);