using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(.*)JSESSIONID=.*((?=\""\s\"").*)$";
string substitution = @"$1JSESSIONID=#######$2";
string input = @"189.222.1.46 - - [24/Jul/2014:11:27:00] ""GET /flower_store/product.screen?product_id=RP-SN-01 HTTP/1.1"" 200 10897 ""http://mystore.splunk.com/flower_store/category.screen?category_id=BALLOONS&JSESSIONID=SD1SL10FF3ADFF3"" ""Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070223 CentOS/1.5.0.10-0.1.el4.centos Firefox/1.5.0.10"" 527 3006
10.2.91.38 - - [24/Jul/2014:11:28:00] ""POST /flower_store/j_signon_check HTTP/1.1"" 302 309
""http://mystore.splunk.com/flower_store/enter_order_information.screen&JSESSIONID=SD1SL10FF3ADFF3"" ""Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070223 CentOS/1.5.0.10-0.1.el4.centos Firefox/1.5.0.10"" 3441 2576
192.0.1.38 - - [24/Jul/2014:11:28:15] ""GET /flower_store/images/cat3.gif HTTP/1.1"" 200 5024 ""http://mystore.splunk.com/flower_store/item.screen?item_id=EST-21&JSESSIONID=SD1SL10FF3ADFF3"" ""Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070223 CentOS/1.5.0.10-0.1.el4.centos Firefox/1.5.0.10"" 4323 3071";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}