re = /(?x)[,](?=([^"]*"[^"]*")*[^"]*$)/m
str = 'abc, pq"r,s", {"one":1, "two":2}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end