use strict;
my $str = 'I would prefer to be a samurai!';
my $regex = qr/^|$/mp;
my $subst = '\\"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";