$re = '/\[\?\](?:[^\[](?![\/\?]))*?%empty%.*?\[\/\?\]/s';
$str = '$a=\'
[?]<h1>%!empty%</h1>
<p>text</p>
[/?]
text
[?]<h1>%empty%</h1>
<p>text</p>
[/?]
text[?]<h1>%!empty%</h1>
<p>text</p>
[/?] \';';
$subst = "ку";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;