const regex = /[^0-9.\n]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^0-9.\\n]+', 'g')
const str = `34 345 324.34 \$
\$34,345,324.34`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);