import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:25[0-5]|2[0-4]\\d|1?\\d{1,2})(?:\\.(?!$)|$)){4}$";
final String string = "validates:\n"
+ "192.68.35.35\n"
+ "0.0.0.0\n"
+ "255.0.0.0\n"
+ "192.168.1.0\n"
+ "192.168.0.1\n"
+ "255.255.255.0\n"
+ "1.1.1.1\n"
+ "255.255.255.255\n"
+ "249.249.249.249\n"
+ "200.200.200.200\n"
+ "199.199.199.199\n"
+ "100.100.100.100\n"
+ "99.99.99.99\n"
+ "0.0.0.0\n"
+ "9.9.9.9\n"
+ "10.10.10.10\n"
+ "99.99.99.99\n"
+ "100.100.100.100\n"
+ "109.109.109.109\n"
+ "110.110.110.110\n"
+ "199.199.199.199\n"
+ "200.200.200.200\n"
+ "249.249.249.249\n"
+ "250.250.250.250\n"
+ "255.255.255.255\n"
+ "01.01.01.01\n"
+ "09.09.09.09\n"
+ "192.168.0.1\n"
+ "255.255.255.255\n"
+ "1.1.1.1\n\n"
+ "should not validate:\n"
+ "256.256.256.260\n"
+ "192.168.0.0/24\n"
+ "192.168..1\n"
+ "192.168.1\n"
+ "1\n"
+ "1.\n"
+ "1.1\n"
+ "1.1.\n"
+ "1.1.1\n"
+ "1.1.1.\n"
+ "1.1.1.1.\n"
+ "1.1.1.1.1\n"
+ ".1.1.1.1\n"
+ "1.0.0.1.0\n"
+ "010.1.1.1\n"
+ "123456\n"
+ "123123123123\n"
+ ".127.0.0.1\n"
+ "192.168.0.1000\n"
+ "300.168.0.1\n"
+ "192.168.0.1.\n"
+ "192.168.0..1\n"
+ "192.16a8.0.1\n"
+ "123.234.345\n"
+ "123.123\n"
+ "11.11.1\n"
+ ".192.168.0.1\n"
+ ".192.168.0.\n"
+ ".192.168.0\n"
+ "....\n"
+ ".......\n"
+ "........";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}