# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\\RequirePackage(\[([^][]*)\])?([^{]*){([^{}]*)}.*(?:\n\s*\[([^][]*)])?"
test_str = ("\\RequirePackage[\n"
" top = 2.5cm,\n"
" bottom = 2.5cm,\n"
" left = 2.5cm,\n"
" right = 2.5cm,\n"
" marginparwidth = 2cm,\n"
" marginparsep = 2mm,\n"
" heightrounded\n"
"]{geometry}%\n"
" [2020-01-02]\n\n"
"\\RequirePackage{tocbasic}\n\n"
"\\RequirePackage[svgnames]%\n"
" {xcolor}%\n"
" [2023/11/15]\n\n"
"\\RequirePackage[raggedright]% OK?\n"
" {titlesec}\n\n"
"\\RequirePackage{xcolor}%\n"
" [2022/06/12]\n\n"
"\\RequirePackage{hyperref}% To load after titlesec!\n"
" [2023-02-07]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.