$re = '/(?<=^|\s)([a-z])(?:\.\1?){5,6}\1(?=$|\s)/m';
$str = 'a.a.a b.b..b c....c....c d...d..d e.e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);