$re = '/\[([+-]?\d+\.\d+)\s*,\s*([+-]?\d+\.\d+)\s*\]?/m';
$str = '[[42.30722,-83.181125],[42.30722,-83.18112667],[42.30722167,-83.18112667,[42.30721667,-83.181125],[+42.30721667,-83.181125]]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);