$re = '/((_).*?){2}/';
$str = 'test_test_test_test_test';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);