$re = '/^(?:(?:(?!\1)()|\1 )(?:(?!\2)()fat|(?!\3)()cat)){1,2}$/';
$str = 'fat cat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);