import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9_]+)(?=:)";
final String string = "[FelixStartLevel] com.adobe.livecycle.content.core-bundle com.adobe.livecycle.content.model.impl.RegisterTypeInternal(3179)] The activate method has thrown an exception (com.adobe.livecycle.content.model.exception.ModelException: ModelException: {Code}-LCC-REP-FCT-002, {Message}-Access denied)\n"
+ "com.adobe.livecycle.content.model.exception.ModelException: ModelException: {Code}-LCC-REP-FCT-002, {Message}-Access denied\n"
+ " at com.adobe.livecycle.content.repository.utils.ExceptionUtil.getException(ExceptionUtil.java:52)\n"
+ " at com.adobe.livecycle.content.repository.utils.ExceptionUtil.getException(ExceptionUtil.java:171)\n"
+ " at com.adobe.livecycle.content.model.annotation.persister.AnnotationPersister.persistAnnotations(AnnotationPersister.java:156)\n"
+ " at com.adobe.livecycle.content.model.impl.RegisterTypeInternal.registerTypeInternal(RegisterTypeInternal.java:144)\n"
+ " at com.adobe.livecycle.content.model.impl.RegisterTypeInternal.registerFileObjectasUnregisteredType(RegisterTypeInternal.java:294)\n"
+ " at com.adobe.livecycle.content.model.impl.RegisterTypeInternal.activate(RegisterTypeInternal.java:92)\n"
+ " at sun.reflect.GeneratedMethodAccessor103.invoke(Unknown Source)\n"
+ " at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)\n"
+ " at java.lang.reflect.Method.invoke(Method.java:498)\n"
+ " at org.apache.felix.scr.impl.inject.BaseMethod.invokeMethod(BaseMethod.java:224)\n"
+ " at org.apache.felix.scr.impl.inject.BaseMethod.access$500(BaseMethod.java:39)\n"
+ " at org.apache.felix.scr.impl.inject.BaseMethod$Resolved.invoke(BaseMethod.java:617)\n"
+ " at org.apache.felix.scr.impl.inject.BaseMethod.invoke(BaseMethod.java:501)\n"
+ " at org.apache.felix.scr.impl.inject.ActivateMethod.invoke(ActivateMethod.java:302)\n"
+ " at org.apache.felix.scr.impl.inject.ActivateMethod.invoke(ActivateMethod.java:294)\n"
+ " at org.apache.felix.scr.impl.manager.SingleComponentManager.createImplementationObject(SingleComponentManager.java:298)\n"
+ " at org.apache.felix.scr.impl.manager.SingleComponentManager.createComponent(SingleComponentManager.java:109)\n"
+ " at org.apache.felix.scr.impl.manager.SingleComponentManager.getService(SingleComponentManager.java:906)\n"
+ " at org.apache.felix.scr.impl.manager.SingleComponentManager.getServiceInternal(SingleComponentManager.java:879)\n"
+ " at org.apache.felix.scr.impl.manager.SingleComponentManager.getService(SingleComponentManager.java:823)\n"
+ " at org.apache.felix.framework.ServiceRegistrationImpl.getFactoryUnchecked(ServiceRegistrationImpl.java:347)\n"
+ " at org.apache.felix.framework.ServiceRegistrationImpl.getService(ServiceRegistrationImpl.java:247)\n"
+ " at org.apache.felix.framework.ServiceRegistry.getService(ServiceRegistry.java:344)\n"
+ " at org.apache.felix.framework.Felix.getService(Felix.java:3699)\n"
+ " at org.apache.felix.framework.BundleContextImpl.getService(BundleContextImpl.java:470)\n"
+ " at org.apache.felix.scr.impl.manager.SingleRefPair.getServiceObject(SingleRefPair.java:72)\n"
+ " at org.apache.felix.scr.impl.inject.BindMethod.getServiceObject(BindMethod.java:648)\n"
+ " at org.apache.felix.scr.impl.manager.DependencyManager.getServiceObject(DependencyManager.java:2201)\n"
+ " at org.apache.felix.scr.impl.manager.DependencyManager$SingleStaticCustomizer.prebind(DependencyManager.java:1118)\n"
+ " at org.apache.felix.scr.impl.manager.DependencyManager.prebind(DependencyManager.java:1520)\n"
+ " at org.apache.felix.scr.impl.manager.AbstractComponentManager.collectDependencies(AbstractComponentManager.java:1006)\n"
+ " at org.apache.felix.scr.impl.manager.SingleComponentManager.getServiceInternal(SingleComponentManager.java:859)\n"
+ " at org.apache.felix.scr.impl.manager.SingleComponentManager.getService(SingleComponentManager.java:823)\n"
+ " at org.apache.felix.framework.ServiceRegistrationImpl.getFactoryUnchecked(ServiceRegistrationImpl.java:347)\n"
+ " at org.apache.felix.framework.ServiceRegistrationImpl.getService(ServiceRegistrationImpl.java:247)\n"
+ " at org.apache.felix.framework.ServiceRegistry.getService(ServiceRegistry.java:344)\n"
+ " at org.apache.felix.framework.Felix.getService(Felix.java:3699";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}