$re = '/\b(?<!["\'])\w+\b(?![\'"])/m';
$str = 'foo \'bar\' baz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);