$re = '/^(the )?t(?!he ).*/m';
$str = 'the tom
the john
tom';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);