const regex = new RegExp('(?:\\G(?!\\A)|\\[)
[^\\d\\]]*
\\K
\\d+', 'g')
const str = `strings123[abc123<span>123</span>def<span>456</span>123]strings456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}