import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\*\\*\\*trash[0-9]+\\*\\*\\*)(\\w+\\s\\w+)(?:\\s[^\\D]+\\s)";
final String string = "random text 1***trash24***y6f dhy 63 month ago 14 minutes, 29 seconds 3,620 name***trash3***random text 1\",\"random text 2***trash2***pot 5aq 3 months ago 9 minutes, 9 seconds 226,629 name***trash3***random text 2\",\"random text 3***trash2***uan 4fp 5 months ago 26 minutes 506,950 name***trash3***random text 3\"\n\n"
+ "и тут тоже $1 то что тебе нужно\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}