package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{1,4}(\.\d{1,2})?|\d{5}(\.\d)?|\d{6})$`)
var str = `1
1.2
1.23
12
12.1
12.12
123
123.1
123.12
1234.12
12345
12345.1
12345.12
123456
123456.1
123456.12
12.123
1.234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}