$re = '/^([^a-zA-Z]+)([a-zA-z]+)(.*)$/m';
$str = 'KG
1KG
1KG1
1 KG 2
.KG
KG
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);