$re = '/(?s)(?<=\G(?!^),\n|^pies\n(?=.*\ncakes$))\w+ likes/';
$str = 'pies
bob likes,
larry likes,
harry likes
cakes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);