using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?<=\G(?!^),\n|pies\n(?=.*?cakes))(\w+ likes)";
string input = @"pies
bob likes,
larry likes,
harry likes
cakes";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}