$re = '/(?i)\b(?:jack|frank|Beth)\b/m';
$str = 'Jack\'s turn, Becky\'s or Frank?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);