# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?P<matrix> *\\begin{(?<token>matrix|matrix\*|pmatrix|pmatrix\*|bmatrix|bmatrix\*|Bmatrix|Bmatrix\*|vmatrix|vmatrix\*|Vmatrix|Vmatrix\*|\\left|\\right)}(?:{c+})?\s(?:(?: *one|two|three){0,3} *(-?\d* *)?(?:& ?|(\\\\ *\n)))+ *\\end{\g<token>} *\s?)|\s*\$\s*(?P>matrix) *\$| *\$\$\s(?P>matrix) *\$\$|\s*\\\[\s*(?P>matrix) *\\\]|\s*\\\(\s*(?P>matrix) *\\\))$"
test_str = ("$$\n"
"\\begin{matrix}{ccc}\n"
"10000 & 4 & 3\n"
"1 & -2 & 4\n"
"1 & 2 & 5\n"
"\\end{matrix}\n"
"$$\n\n"
" $$\n"
"\\begin{pmatrix}\n"
"1 & 2 & 3 \\\\\n"
"1 & 2 & 4 \\\\\n"
"1 & 2 & -5 \\\\\n"
"\\end{pmatrix}\n"
" $$\n\n"
" $\n"
"\\begin{matrix}\n"
"1 & 2 & 3 \\\\\n"
"1 & 2 & -4 \\\\\n"
"1 & 2 & 5 \\\\\n"
"\\end{matrix}\n"
"$\n\n"
" \\[\n"
"\\begin{matrix}\n"
"1 & 2 & 3 \\\\\n"
"1 & 2 & 4 \\\\\n"
"1 & 2 & 5 \\\\\n"
"\\end{matrix}\n"
" \\]\n\n"
"\\(\n"
"\\begin{matrix}\n"
"1 & 2 & 3 \\\\\n"
"1 & 2 & 4 \\\\\n"
"1 & -2 & 5 \\\\\n"
"\\end{matrix}\n"
"\\)\n\n"
"\\begin{matrix}\n"
"1 & 2 & 3 \\\\\n"
"1 & 2 & 4 \\\\\n"
"1 & 2 & 5 \\\\\n"
"\\end{matrix}\n\n"
"\\(\n"
"\\begin{matrix}\n"
"1 & 2 & 3 \\\\\n"
"1 & 2 & 4 \\\\\n"
"1 & -2 & 5 \\\\\n"
"\\end{matrix}\n"
"\\]\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.