package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^ ]*-[^ ]*`)
var str = `Details of Test-3K9Y9Y1-My-Node1 give me`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}