using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!fake.*)(man[a-z]?\b|dog)(?!.*fake)";
string input = @"long mane
fake (xxx) - more text - strong man
strong man (?<??????) fake";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}