$re = '/(https:\/\/acme.com.+\.pdf)/m';
$str = 'https://acme.com/docs/
somedirectory/example.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);