import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img[^>]*alt=\"([^\"]+)\"[^>]*>";
final String string = "<span itemprop=\"description\"> <img src=\"//res.smzdm.com/images/emotions/30.png\" alt=\"[小怒]\" class=\"wp-smiley\"> <img src=\"//res.smzdm.com/images/emotions/30.png\" alt=\"[小怒]\" class=\"wp-smiley\"> <img src=\"//res.smzdm.com/images/emotions/30.png\" alt=\"[小怒]\" class=\"wp-smiley\"> 这文章百度哪里搬来的 </span>\n\n"
+ "<span itemprop=\"description\"> <img src=\"//res.smzdm.com/images/emotions/36.png\" alt=\"[喜极而泣]\" class=\"wp-smiley\"> 年少无知看了那篇文章好奇买了4瓶 喝了一口差点吐出来 </span>\n\n"
+ "<span itemprop=\"description\">国内咋就没厂商做点纯气泡水呢,成本应该不高吧,钱都让屈臣氏巴黎水赚去了 <img src=\"//res.smzdm.com/images/emotions/23.png\" alt=\"[皱眉]\" class=\"wp-smiley\"> </span>\n\n"
+ "<span itemprop=\"description\">小时候就经常煲来喝,利尿排毒 <img src=\"//res.smzdm.com/images/emotions/45.png\" alt=\"[抽烟]\" class=\"wp-smiley\"> </span>\n\n"
+ "<p class=\"p_content_166651051\"><span itemprop=\"description\">我喜欢香草味的,滑滑的感觉 </span></p>\n\n"
+ "<p class=\"p_content_166650868\"><span itemprop=\"description\">我喝过好几箱,后来还回购了,再后来就喝不起了,太贵[皱眉] </span></p>";
final String subst = "\\g<1>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}