$re = '/[+7]([0-9]{10})$/m';
$str = '+79001234567
+7900123456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);