re = / +\/ +/m
str = 'a name / another name / something else'
subst = '/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result