re = /(?:(?:25[0-5]|(?:2[0-4]|1[0-9]|[1-9]|)[0-9])(?:\.(?!$)|$)){4}/m
str = 'validates:
0.0.0.0:0
255.0.0.0
192.168.1.0:8080
does not validate:
192.168.0.0/24
192.168..1
192.168.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end