package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ab(cd|de)*`)
var str = `abcd abde abcdcd abdedede`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}