using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?=.*?<|>)^\s*(.+?)\s*<([\]+@[\w-]+(?:\.[\w-]+)+)>s*$|^([\w\.\-]+)@([\w\-]+)((\.(\w){2,3})+)$)+?$";
string input = @"test@domain.com
test user <test@domain.com>
""test user"" <test@domain.com>
""test user"" <test@domain.com
""test user"" test@domain.com>
test user <test@domain.com
test user test@domain.com>
""test user <test@domain.com>
test user"" <test@domain.com>
""test user"" test@domain.com";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}