import re
regex = re.compile(r"(?i)\b(?:Store Number|StreetA|City|State_id|Postal Code|Store Name|Phone Number|Tax Table \d|Artistree Vendor|Store Group|Store Zone number)+\b\s*[–,-]\s*(\w*.*)", flags=re.MULTILINE)
test_str = ("FP Team,\n\n"
"Please install the Live database for store 1384. The updates have been completed.\n\n"
"• Store number - 1384\n"
"• StreetA – 1275 York Rd, Ste 21A\n"
"• City – Gettysburg\n"
"• State_id – PA\n"
"• Postal Code – 17325-7565\n"
"• Store Name – Gettysburg, PA\n"
"• Phone Number – (717) 420-8200\n"
"• Tax Rates\n"
" o Tax table 1 – 6.0000%\n"
" o Tax table 2 – 0.0000%\n"
" o Tax table 3 – 0.0000%\n"
" o Tax table 4 – 0.0000%\n"
" o Tax table 5 – N/A\n"
"• Artistree vendor – Kernersville\n"
"• Store Group – US.201308\n"
"• Store Zone number – 2030")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")