$re = '/((?<=[\s\.])\-+)|(\-+(?=[\s\.]))/';
$str = 'This- -is - a test-sentence. -Test- --- One-Two--Three---Four----.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);