# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)(?=.*:.*~.*~.*?\1_(.{4}).*?(,))/$3$2/g;t' <<< "#162:~;0101_1000;0110_1001;0111_1010;1000_1011;1001_1100;1010_1101;1011_1110;1100_1111,~0_00001_00012_00103_00114_01005_01016_01107_01118_10009_1001,"