# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"what color is.*(?:my|your|his|her).*(?:bright red|blue|green|lemon chiffon)?.*"
test_str = ("ex1: I am * years old\n"
"valid matches:\n"
"- \"I am 24 years old\"\n"
"- \"I am twenty four years old\"\n\n"
"ex2: what color is [my|your|his|her] (bright red|blue|green|lemon chiffon) *\n"
"valid matches:\n"
"- \"what color is his lemon chiffon car\"\n"
"- \"what color is my some random text till the end of string\"\n\n"
"ex3: [*] told me to say *\n"
"valid matches:\n"
"- \"Bob and Alice told me to say hallelujah\"\n"
"- \"told me to say by nobody\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.