package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^t]*t){2}[^t]*`)
var str = `This is a test string with five t's`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}