$re = '/^(?:.*?t){2}(?:(?!t).)*/m';
$str = 'This is a test string with five t\'s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);