import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\bGASTEC).*(?:NO\\s|,\\s)(?<id>\\b[1-9][ABHLMT][ABLMT]{0,1}|[1-9][0-9]{1,2}\\s?[^-Pm ][BDLPT]{0,2})(?:\\s|,).*$";
final String string = "GASTEC TUBE, BENZENE 1-10 PPM, 121L, //MUST MATCH\n"
+ "121L TUBE, BENZENE 1-10 PPM, GASTEC, //MUST MATCH <<<<-----\n"
+ "GASTEC TUBE FOR H2S, 0.5-15 PPM, //NO MATCH\n"
+ "GASTEC TUBE FOR CO, 1-25 PPM,//NO MATCH\n"
+ "KITAGAWA 128SD//NO MATCH\n"
+ "GASTEC TUBE FOR ETHYL ALCOHOL NO 112L , 100-2000 PPM,//MUST MATCH\n"
+ "GASTEC TUBES NO 111 METHYL ALCOHOL QC NO: 80777 MEASURING RANGE: 0.02-4.5% SCALE RANGE: 0.02-1.5%//MUST MATCH\n"
+ "GASTEC TUBES NO 4H BENZENE QC NO: 90985 MEASURING RANGE: 0.2-66 PPM SCALE RANGE: 0.2-20PPM//MUST MATCH\n"
+ "MSA TUBES NO 111 METHYL ALCOHOL QC NO: 80777 MEASURING RANGE: 0.02-4.5 SCALE RANGE: 0.02-1.5 (2)//NO MATCH\n"
+ "GASTEC TUBES NO 121SP BENZENE QC NO: 90985 MEASURING RANGE: 0.2-66 PPM SCALE RANGE: 0.2-20PPM (1)//MUST MATCH\n"
+ "GASTEC TUBE FOR BENZENE (RANGE 0.1-10 PPM) , 5 TEST S EACH PACKET, //NO MATCH\n"
+ "DRAGER TUBES NO 121SP BENZENE QC NO: 90985 MEASURING RANGE: 0.2-66 PPM SCALE RANGE: 0.2-20PPM 1 //NO MATCH\n"
+ "TOXIC GAS DETECTION TUBES, GASTEC General Deck Stores, Man: IMPA //NO MATCH\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}