import re
regex = re.compile(r"(?<=href=\").+?(?=\")", flags=re.MULTILINE)
test_str = "<li><a href=\"Submissions%253ASpatioTemporalExtent.html\" title=\"Submissions:SpatioTemporalExtent\"> Submissions:SpatioTemporalExtent </a></li><li><a href=\"Submissions%253AParticipantRole.html\" title=\"Submissions:ParticipantRole\"> Submissions:ParticipantRole </a></li><li><a href=\"Submissions%253AAgentRole.html\" title=\"Submissions:AgentRole\"> Submissions:AgentRole </a></li><li><a href=\"Submissions%253AObjectrole.html\" title=\"Submissions:Objectrole\"> Submissions:Objectrole </a></li><li><a href=\"Submissions%253AInformation_realization.html\" title=\"Submissions:Information realization\"> Submissions:Information realization </a></li><li><a href=\"Submissions%253AInformationObjectsAndRepresentationLanguages.html\" title=\"Submissions:InformationObjectsAndRepresentationLanguages\"> Submissions:InformationObjectsAndRepresentationLanguages </a></li><li><a class=\"new\" href=\"http://ontologydesignpatterns.org/wiki/index.php?title=Submissions:InformationObject&action=edit&redlink=1\" title=\"Submissions:InformationObject (not yet written)\"> Submissions:InformationObject </a></li><li><a href=\"Submissions%253AEventProcessing.html\" title=\"Submissions:EventProcessing\"> Submissions:EventProcessing </a></li>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")