re = /(?<=<|\s)[a-zA-Z:_][a-zA-Z:_.*][^=|\s]+/m
str = '<button type="sasasasasa" abcd="dsqdsq" efgh="sasasa">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end